Online Talk to our
support team or
sales department.
Dec 5th, 2022, 5:50am
Welcome, Guest. Please Login or Register.
Pages: 1  Reply Reply  Notify of replies Notify of replies  Print Print
   Author  Topic: virtual port pair working unexpectedly  (Read 2898 times)
virtualuser
FabulaTech Forum Newbie
*



View Profile         
Posts: 2
virtual port pair working unexpectedly
« on: Jul 7th, 2009, 12:13pm »
Quote Quote  Modify Modify

hi, using v5.0.1, i have a pair of virtual serial ports (eg. com10 to com11) and using this pair between two apps.  i would change app1 baudrate to 19200 and keep app2 baudrate to 9600.  i expected communication to fail - but communication did not fail - it continued to send/receive message  Huh.  i've also played with properties - toggle on bitrate emulation, full handshake, toggle on DTR to RI and DTR to DCD.  but communication on the virtual port pair continues to work.   when i hook up the two apps with physical serial ports and cable and then change the baudrate on 1 app - communication fails as expected.  what's up with virtual ports?  btw, if you want to see messages just pass through, virtual ports a great help.
IP Logged
George_White
FabulaTech Forum Senior Member
****



View Profile         
Posts: 307
Re: virtual port pair working unexpectedly
« Reply #1 on: Jul 8th, 2009, 1:46am »
Quote Quote  Modify Modify

virtualuser,
 
Currently our driver does not allow terminating the connection when baud rates are different. In emulating baud rate we added delays in data transfer in order to correspond to the hardware com port baud rate. If exact emulation of a hardware com port is a necessary requirement for you, we'll keep this in mind for our future releases of the software.
 
Thanks!
IP Logged
virtualuser
FabulaTech Forum Newbie
*



View Profile         
Posts: 2
Re: virtual port pair working unexpectedly
« Reply #2 on: Jul 8th, 2009, 9:26am »
Quote Quote  Modify Modify

hi, thanks for quick reply Smiley.  that would be nice.  but not necessary for us.  we can't wait for fix and moving onto digiports.  thank you!
IP Logged
Sergey_Jarovski
FabulaTech Forum Moderator
FabulaTech Forum God
*****



View Profile   WWW         
Gender: male Posts: 553
Re: virtual port pair working unexpectedly
« Reply #3 on: Aug 26th, 2015, 1:52am »
Quote Quote  Modify Modify

Hi !
The full emulation of hardware communication can't be realize in VSPK.
We are using the buffering of data on the driver level if baud rates are different.
Please describe in detail the requirements for your project.
I would gladly see if we can help you with any of our solutions.
IP Logged

Sergey Jarovski

FabulaTech
===================
http://www.fabulatech.com
Pages: 1  Reply Reply  Notify of replies Notify of replies  Print Print

« Previous topic | Next topic »